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Using the Line Style 
Editor
This document contains installation and use instructions for the Line Style Editor 
(MILISTED), which you can use with MapInfo Professional.
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What is the Line Style Editor?
The MapInfo Line Style Editor (MILISTED) allows you to create custom line styles and modify 
existing line styles to enhance the look of your MapInfo Professional maps. This works by modifying 
the line style definition file(s) from which MapInfo Professional reads the definitions. Using the Line 
Style Editor, you can open any valid MapInfo Professional line style definition file, modify it and 
create new line styles of your own. 

A line style definition file (like Samples.Pen, which we use for this document) can contain one or 
more line styles. Using the Line Style Editor you can add, modify, delete, and reorder the line style 
definitions within the file. Each line style definition displays in the Line Style and the Region Style 
dialog boxes in the order they appear in the line style definition file. 

There can be multiple line style definition files, but the file MapInfo Professional primarily uses is 
named MAPINFOW.PEN. The line styles you create or edit are available only when you re-open 
your MapInfo product, because that is what prompts the program to read the mapinfow.pen file.

Installing the Line Style Editor 
The Line Style Editor is available as a free download from:
http://go.pbinsight.com/line-style-editor

After saving the download file (called lineedit.exe) to your machine, do the following to install it:

1. Go to the directory into which you placed the Line Style Editor download file and for: 
• Windows XP, 2008– double-click the lineedit.exe file to start the installation process. 

If you see an Open File - Security Warning stating that the publisher could not be verified, 
click Run to continue.

• Vista, Windows 7 – right-click the lineedit.exe file and select Run as Administrator from 
the popup menu to install using elevated privileges. A prompt for permission to continue 
displays. Click Allow or Yes to proceed (if you do not respond and the message times-out, 
the install is unsuccessful).

2. In the InstallShield Self-Extracting EXE dialog box, click Yes to begin the install process.

3. In the Welcome screen, click Next.

4. In the Software License Agreement screen, click Yes to accept the terms of the license.

5. In the Choose Destination Location screen, do one of the following: 
• Click Next to accept the default file destination location and continue 
• Click Browse and select the path to which you would like to install the Line Style Editor. 

To install this product on the network or to select another drive, click the Network button. 
When you have finalized the path in the Path field, click OK to return to the Choose 
Destination dialog box. Click Next to continue. 

6. In the Select Program Folder screen, choose the MapInfo folder from the Existing Folders list or 
type in a new folder name in the Program Folders field. Click Next to begin the installation. 

7. Click Finish to close the Setup Complete dialog box. 
Line Style Editor 2.0 6 User Guide

http://go.pbinsight.com/line-style-editor


Chapter 1: Using the Line Style Editor
Understanding the Line Style Editor
Understanding the Line Style Editor
To start the Line Style Editor, do one of the following: 

• Double-click the MILISTED icon, 
• From the Start menu, select All Programs > MapInfo > MapInfo Line Style Editor. Using 

either method, the Line Style Editor window displays. 

Figure: Figure: Line Style Editor Main Menu, Toolbar and Status Bar 

1) menu, 2) toolbar, 3) line style definition file, 4) status bar

Line style definition files have the extension .pen. 

Understanding the Layers and Objects 
Before you try to create your own line style definition, it is important to understand the Line Style 
Editor's concept of layers and objects. Each line style definition can consist of one or more layers. 
Layers control the order line objects are drawn in. Lines and tick marks drawn in an upper layer 
cover those drawn in lower layers. Using the Line Style Editor utility, you can add, modify, delete, 
and reorder the layers in a line style definition. 

Each layer in a line style definition can contain one or more objects. Objects are the elements that 
make up a line, such as straight line segments, perpendicular line segments, angles, etc. Objects 
can be grouped into two types: 

• Visible Objects – Determines how the line looks 
• Control Objects – Determine how the line behaves in MapInfo Professional You can use the Line 

Style Editor to add, modify, move, and delete objects from a layer. 

1

2
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Working with Visible Objects 

Visible objects are the objects that you see when you build and display a line style definition. You 
create the visible objects and are repeated to create the look of the line. A preview line displays 
above the line you are creating to show you how the line looks as you create it. The visible objects 
include: 

• Draw line – Creates a horizontal line in your line style definition. You can control the length and 
width of the line using the line options. You can only draw a line in one layer at a time. You can 
double-click a Draw line Object to review and edit the line's properties. 

Figure: Figure: Draw Example

1) line style preview, 2) line style definition
• Tick mark – Creates a vertical line that runs perpendicular to the draw line. You can specify the 

starting point, the width, and the distance from the center of the line in either direction. You can 
double-click a Tick Mark Object to review and edit the mark's properties. 

You can specify the color in the Line Style Editor or you can pick a color later using the 
line style commands in MapInfo Professional. 

Figure: Figure: Draw with Tick Mark Example 

• Angle tick mark – Creates left and right pointing angle marks that run perpendicular to the draw 
line. You can directly specify the angle tick mark's starting point and how far from the center of 
the line it extends in either direction. You can double-click an Angle Tick Mark object to review 
and edit the mark's properties. 

Figure: Figure: Angle Tick Examples

• Draw line to end – Extends the draw line to the end of the specified line. You can directly 
specify the starting point and width of the line with a display attribute object. You can double-click 
a Draw line to End Object to review the line's properties. 

1

2
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Figure: Figure: Draw to End Example

Working with Control Objects 

Control objects manage how and where MapInfo Professional draws the visible objects. Control 
objects include: 

• Skip – Whenever there is a gap between one object and another in a layer, the Line Style Editor 
automatically inserts a skip object for that gap. You must insert Skip to End Objects explicitly 
when you want one. The Line Style Editor uses the skip objects implicitly. 

• Skip to end – Displays the visible object in the current layer once, at the beginning of the line 
and prevents that object from repeating. 

• Loop – Inserts a moveable vertical line that specifies where the line should begin repeating. All 
objects to the left of the line are static and display only at the beginning of the line. All objects to 
the right of the line repeat until the end of the line style. To edit the position of this loop line, 
double-click the line and enter a new position. 

• Draw Tools Property – Allows you to specify the pen properties for the layer. 

Figure: Draw Tools Property 

Draw Tools Property attributes control how the line style in the current layer is drawn. It is 
considered an object and not just a place holder for the attributes of other objects. A pen 
property object placed before a loop object only affects those objects drawn before it encounters 
another pen property object which can have different attributes. This is how you create different 
colors in your line style. By default, MapInfo Professional draws the objects in a layer in the order 
they appear and then repeats them from the beginning until the end of the line. Then it does the 
same with any additional layers defined. 

Working with the Line Style Definition File 
The line style definition file (the file that ends in .PEN) contains the line styles that have been created 
for use in MapInfo Professional maps. Using the instructions below, you can create and edit a line 
styles file. It is important to remember that any changes you make to a line style must be saved not 
only within the line style itself but also to the line style definition file. 
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Adding a New Line Style to the Definition File 
When you open a line style definition file (with a .PEN extension), the Line Style Editor displays a 
numbered list of the defined line styles in it. You can add new line styles to the end of the list. 

To add a new line to a file: 

1. Open the line style file to which you want to add a line style. 

2. In the Edit menu, select the New Line option. The Line Style Editor creates a new, blank line 
and adds it to the end of the file. It also opens a new window for the new line style. 

Moving a Line in a Line Style Definition File 
You can move a line style within a definition file to a new position in the line style list. To move an 
object: 

1. Click the line style in the list. 

2. Drag it to a new position in the list. 

Figure: Figure: Moving a Line Style in a Line Style Definition File 

MapInfo Professional displays the line styles in the Line Style dialog box in the same 
order that the Line Style Editor shows them here. 

3. Click the Save tool  to save the Line Style Definition file. 

Deleting a Line Style from the Definition File 
You can remove a line from a line style definition file. 

1. In the Line Style Definition File window, click the line style you want to delete. 
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2. Do one of the following: 
• Press the Delete key 
• In the Edit menu, select Delete. The Line Style Editor removes that line style from the line 

style definition file. 

3. Click the Save tool  to save the Line Style Definition file. 

Copying a Line Style to a Different Position in the Definition File 
You can copy an existing line and paste it to the end of the file. 

1. In the line style definition file window, click the line you want to copy. 

2. In the Edit menu, select Copy. 

3. To paste the line in a new position, in the Edit menu, select Paste. The Line Style Editor pastes 
a copy of the line you selected at the end of the file. 

4. Click the Save tool  to save the Line Style Definition file. 

Working with Line Styles 

Creating and Opening a Line Style 
When you start the Line Style Editor, it displays an empty window. You can either create a new line 
style definition file or open an existing one. 

• To create a new line style definition: From the File menu, select New, or
• To open an existing line style definition: From the File menu, select Open and specify the name 

and location of an existing line style definition file. The Line Style Editor shows the contents of a 
line style definition file in a child window. You can 

open more than one line style definition file at a time; the Line Style Editor displays each one in a 
separate window. 

Saving a Line Style 
The changes you make do not exist in the line style definition file until you explicitly save them. 

To save a file: 

1. Select the line style definition file window that you want to save. 

2. In the File menu, select Save or Save as and type a name for the file in the field provided. The 
Line Style Editor writes all your changes to the line style definition file you specify. 
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MapInfo Professional only reflects the changes if that file is named MAPINFO.PEN and is located in 
the appropriate user directory. 

Line style definitions you save are available to you in the Line Style and the Region Style 
dialog boxes the next time you open MapInfo Professional. If you create or modify line styles 
while MapInfo Professional is open, the changes do not display. 

Editing a Line Style 
You can modify the layers and objects that make up a line style definition. 

1. In the line style definition file (.PEN) window, click the line you want to modify. 

2. Press the Enter key or in the Edit menu, select Modify. The Line Style Editor displays a new 
window with the contents of that line. 

3. Click the Save tool  to save the Line Style Definition file. 

Working with Objects in a Line Style 
Objects are the visible and control features that make up a line style. 

Adding a New Object to a Line Style 
You can add new objects to any layer of a line style definition. 

1. Click the layer to which you want to add an object. 

2. Optionally, click the existing object after which you want the new object inserted. If you do not 
click an existing object, the Line Style Editor inserts the new object as the first object in the layer. 

3. In the Edit menu, select New Object and choose an object type. 

4. Click the Save tool  to save the Line Style Definition file. 

Moving an Object in a Line Style 
You can move objects from side to side in a layer. 

1. Click the object you want to move. 

2. When the Line Style Editor draws a white rectangle around the object, move the cursor to the 
center of the object until it changes into a four-headed arrow. 
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Figure: Figure: Moving an Object Example 

3. Click there and drag the object to the left or the right. You cannot move some objects past 
others. For example, you cannot pass a tick mark object over a draw line object. 

Deleting an Object from a Line Style 
You can delete an object from any layer. 

1. Click the object you want to delete. 

2. Press the Delete key or in the Edit menu, select Delete. The object you selected is deleted. 
There is no prompt and the change is saved automatically. 

Resizing an Object in a Line Style 
You can change the size of an object. Most objects can only be changed along one axis. 

1. Click the object you want to resize. 

Figure: Figure: Resize Object Example 

The Line Style Editor draws a white rectangle around the entire object. 

2. Move the cursor to the edge of the object until it changes into a two-headed arrow. 

3. Click there and drag the edge of the layer to the desired length. You can make draw line objects 
longer or shorter. You can make tick marks taller or shorter. 

4. Click the Save tool  to save the Line Style Definition file. 

Changing an Object's Properties 
You can explicitly set an object's position and size. 

1. Click the object whose properties you want to change. 

2. Press Enter or in the Edit menu, select Property. 
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Figure: Figure: Draw Property 

The Line Style Editor displays a dialog in which you can enter the object position, length or height 
and width. 

1. Make your selections and entries and select OK to confirm the changes. 

2. Click the Save tool  to save the Line Style Definition file. 

Working with Layers 
You can enhance the look of a line style by adding layers. Layers can add color and depth to a line 
style. 

Adding a New Layer to a Line Style 
You can add new layers to a line style definition. 

1. Select the line style definition window. 

2. In the Edit menu, select New Layer. The Line Style Editor draws a new layer grid in the line style 
definition window. 

Moving a Layer in a Line Style 
You can move layers within a line style definition window to change the order in which MapInfo 
Professional displays them. 

1. Click the layer you want to move. 

2. Drag it to the new position. 

3. Click the Save tool  to save the Line Style Definition file. 

Deleting a Layer from a Line Style 
You can delete a layer so that it is no longer a part of the line style definition. 

1. Click the layer you want to delete. 

2. Press the Delete key or in the Edit menu, select Delete. 
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3. Click the Save tool  to save the Line Style Definition file. 

Copying a Layer to a Location in a Line Style 
You can copy an existing layer and paste it to the end of the line style definition window. 

1. Click the layer you want to copy. 

2. In the Edit menu, select Copy. 

3. To paste the layer in a new place, choose the Edit menu and select Paste. The Line Style Editor 
pastes a copy of the layer you selected at the end of the line style definition window. 

4. Click the Save tool  to save the Line Style Definition file. 

Changing the Length of a Layer 
You can change the length of a layer. Different layers in the same line style definition do not need to 
be the same length. The length of a layer defines how frequently MapInfo Professional repeats the 
objects in that layer when drawing the line. The Line Style Editor adds an implicit skip object after the 
last object in a layer to reach the length of that layer. 

1. Click the layer whose length you want to change. 

2. When the Line Style Editor draws a white rectangle around the entire layer, move the cursor to 
the right edge of the layer until it changes into a little two-headed arrow. 

3. Click there and drag the edge of the layer to the right or the left. 

Changing the Width of a Layer 
You can change the width of a layer. This merely gives you more room to draw objects in the Line 
Style Editor. MapInfo Professional is only concerned with the width of visible objects. 

1. Click the layer whose width you want to change. 

2. When the Line Style Editor draws a white rectangle around the entire layer, move the cursor to 
the top or bottom edge of the layer until it changes into a two-headed arrow. 

3. Click there and drag the edge of the layer up or down. 

Changing the Properties of a Layer 
You can explicitly set a layer's width and height. 

1. Click the layer whose properties you want to change. 

2. Press Enter or in the Edit menu, select Property. 

3. The Line Style Editor displays a dialog in which you can enter the layer height and width. Make 
your entries and select OK to complete the changes. 
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Frequently Asked Question 
Can I use maps with custom lines styles in other copies of MapInfo Professional? 

The actual line-style definition resides in the MAPINFOW.PEN file. MapInfo Professional only stores 
an index number in the tables to indicate which lines style to use. If you create a map that refers to 
styles in a custom mapinfow.pen, a different copy of MapInfo Professional that does not have that 
MAPINFOW.PEN file cannot draw those custom line styles. Instead, it uses the line style it finds in 
the MAPINFOW.PEN file with the specified index number. If there is no line style with that index 
number, MapInfo Professional uses a simple solid line. 

To import a custom MAPINFOW.PEN file to a new computer, copy the custom file to the same 
location as the existing MAPINFO.PEN file in the current user's Application Data directory. If the 
current .PEN file also contains custom line styles, it may be a good idea to rename the existing 
MAPINFO.PEN file so that nothing is lost. 

It is necessary to close and re-open MapInfo Professional to make new custom styles 
available. 
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Line Style Menus
Use the following topics as a reference for the menus used in the Line Style 
Editor. 

In this chapter
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File Menu Options

Edit Menu Options

Menu Option Description 

New Creates a new .PEN file. 

Open Opens an existing .PEN file. 

Close Closes an opened .PEN file. 

Save Saves an opened .PEN file using the same name. 

Save As Saves an opened .PEN file using a name you specify. 

File 1, 2, 3, 4 Quick opens one of the four most recently opened .PEN files. 

Exit Exits the Line Style Editor. 

Menu Option Description 

Cut Deletes selected data from the current window and moves it to the clipboard. 

Copy Copies selected data from the current window to the clipboard. 

Paste Pastes data from the clipboard into the end of current window. 

Delete Deletes selected object. 

New Line Adds line style to the last position of current window. 

New Layer Adds layer to the last position of current window. 

New Object Adds a new object into layer. 

Modify Modifies selected line style. 

Property Displays Property dialog box of selected object. 
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Objects Menu Options

Options Menu Options
The Options menu options do not affect the contents of .PEN file. These options are used to change 
the appearance of the line styles in the Line Style Editor with user width and user color. The Options 
Menu is only active when there is an open .PEN file. 

View Menu Options 

Window Menu Options

Menu Option Description 

Next Selects next object. 

Previous Selects previous object. 

Menu Option Description 

Line Width Selects the width of the line. 

Line Color Selects the color of the line. 

Background Color Selects the color of the background. 

Menu Options Description 

Toolbar Shows or hides the toolbar. 

Status Bar Shows or hides the status bar. 

Menu Options Description 

New Window Creates a new window that views the same .PEN file. 

Cascade Arranges windows in an overlapped fashion. 

Tile Arranges windows in non-overlapped tiles. 
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Help Menu Options

Arrange Icons Arranges icons of closed windows. 

Window 1, 2, ... Goes to specified window. 

Menu Options Description 

Index Offers you an index to topics on which you can get help. 

Using Help Provides general instructions on using help. 

About Displays the version number of this application. 

Menu Options Description 
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